0 votos
1.6k vistas
por Novato (101 puntos)   en QGIS

Hola


Después de muchos foros y vueltas no logro dar con el problema. Espero no sea una molestia.
la situación es la siguiente.

A partir de un wfs (donde al conectar sale relacionado EPSG:6247) agregue varias capas (que solicitan un CRS para ser agregadas) escogí EPSG:3116 tal como estoy trabajando en mi proyecto con varias capas vectoriales y raster. De entrada no quedan ubicadas sobre las que ya tengo aun cuando "al vuelo" esta habilitado. Asumiendo que es problema de la proyección en la que se encuentra procedo a reproyectar (save as....) y cambio el sistema de coordenada pero la situación se mantiene igual.

Utilizo entonces otras capas ya trabajadas con EPSG 4686 y vuelvo a reproyectar por dos vías (desde capa guardada directamente del wfs con dicha proyección y repitiendo la guardada en 3116 y luego pasando a 4686) sin embargo la situación no cambia. Inclusive descargue nuevamente los .prj y reemplacé en algunas capas para probar y no logre cambio.

Tengo habilitado "al vuelo". la única diferencia que encuentro es que "extent" cambia en el metadata pero tengo entendido que este cambia según se reproyecte es decir, no es independiente de modificación con respecto al CRS. 

alguna idea ? estoy como loco tratando de entender algo que no tiene sentido. La búsqueda que he hecho en foros relaciona únicamente este tipo de problemas cuando no se esta trabajando con hay diferentes CRS  y la opción es reproyectar o transformar al vuelo. Creo haber hecho todas las combinaciones posibles pero no logro cambio. 

graciasde antemano por el tiempoejemplo capas con misma proyección sin embargo separadas(transformación al vuelo esta habilitada)

1 Respuesta

0 votos
por Novato (105 puntos)  
Hola, 

Tengo el mismo problema. Tengo dos archivos con SRC diferentes, uno es un vector y el otro es ráster, el tema es que quiero calcular un NDVI sólo para el área de mi vector, por lo cual necesito hacer un corte del ráster utilizando el vector como capa de corte. Sin embargo, cuando intento pasarlos a ambos a 3116 no coinciden. Lo intenté guardando los archivos como capas nuevas y cambiando el SRC, pero no funcionó. Después intenté con las herramientas de proceso de GDAL para ráster (combar (reproyectar)) y vectorial (reproyectar capa) y tampoco funcionó.  No sé que más pueda hacer, espero puedan ayudarme.

Salu2. 
por Experto (1.8k puntos)  
Has probado cargar las capas con la "transformacion al vuelo" desactivada, de esta forma podrías observar en donde se ubican inicialmente las capas, puede estar sucediendo que una de las capas tenga un error de proyección.
Ofertas de trabajo SIG

Un buen usuario

  1. Comparte lo que sabe
  2. Demuestra su amabilidad
  3. Hace preguntas claras
  4. Escribe correctamente
  5. No hace daño a nadie
Gana 500 puntos y obtén un Certificado SIG validado por ArcGeek.

 

...