0 votos
409 vistas

Buenos días forer@s!! acabo de registrarme en el foro y os felicito por vuestra colaboración y aportación.

Quería comentaros una duda por si me podéis ayudar:

Tengo un mxd en el que hay 4 archivos raster jp2 (ortofotos), un shp lineal de carreteras y otro shp lineal de ríos.

Las capas de carreteras y ríos aparecen desplazadas unos 150 metros sobre lo que le correspondería en las ortos. Para intentar solucionar esto, le he dado coordenadas UTM (Ed 50, huso 30) al marco de datos y luego mediante arccatalog le he asignado el mismo sistema de coordenadas a las capas shp sin obtener resultado alguno.

También he probado con ArcToolBox, proyectar y tampoco. Sólo se me ocurre georreferenciarlas pero al ser 4 ortofotos imagino que habrá desplazamientos y es más laborioso.

¿Me podéis dar algún consejo para solucionar y unificar mi sistema de coordenadas?

por Novato (119 puntos)   en ArcGIS
editado por | 409 vistas

1 Respuesta

0 votos

Antes que nada el origen de las ortofotos y shp son de la misma fuente (puede que ahí este el problema, tal vez fueron generadas a diferente escala o los insumos, instituciones o personas usaron una metodología diferente).

Para asignar o definir el sistema de referencia, primero desdes estar completamente seguro que en dicho sistema fue elaborado (definir un sistema de referencia erróneo genera errores), una vez que cada capa ráster o vectorial cuenten con su respectiva proyección (no importa si son diferentes), ahí puedes reproyectar a tu sistema de referencia final, otra opción sería corregir el desplazamiento de los shp con Spatial Adjustment.

por Administrador (7.3k puntos)  
0
Muchas gracias Franz por tu respuesta.
En propiedades tanto de las 4 ortos como de los shp lineal de ríos y carreteras me aparece como sistema de coord. indefinido pero aunque les dé a todos el mismo no se modifica nada.
No sé en qué sistema de referencia se crearon, lo que sé es que ambos shp lineales tienen el mismo sistema de referencia (imagino ed 50) y las ortos aparecen ligeramente desplazadas (150 m) con lo que su sistema de referencia debe ser ETRS89 o WGS 84. ¿cómo se reproyectarían todos en el mismo? a lo mejor no hago bien el procedimiento.
0
Por eso, no debes darles a todos un mismo sistema, sino el correcto, justo con el cual se crearon, si colocas a todos el mismo sistema, estas aceptando que su posición es correcta, al reproyectarlos los enviarás a una posición incorrecta, si mismo no logras conocer su proyección correcta, o bien realizas un ajuste espacial de los vectores, o georreferencias en base a los vectores las imágenes ráster.
0
Gracias Franz, así lo haré entonces.
Ofertas de trabajo SIG

Un buen usuario

  1. Comparte lo que sabe
  2. Demuestra su amabilidad
  3. Hace preguntas claras
  4. Escribe correctamente
  5. No hace daño a nadie
Gana 500 puntos y obtén un Certificado SIG validado por ArcGeek.

 

1,239 preguntas
1,439 respuestas
930 comentarios
3,009 usuarios